Самые интересные и полезные статьи на тему настройки и оптимизации работы компьютеров и оргтехники

Сумма в табличной части

Как рассчитать сумму в строке табличной части 1С

Продолжаем изучать 1С сегодня напишем пару процедур, с помощью которых автоматически будет рассчитываться сумма в строке табличной части. И так это буде продолжение предыдущей статьи, в которой мы свами создавали новый документ. Если кто не читал советую для начал ознакомиться с ней.

Мы создали документ Приход товара. В котором есть дата прихода и Поставщик. В табличной части добавили четыре поля это Наименование, Количество, Цена и Сумма. Все вроде бы нормально но вот по логике нужно сделать так чтобы поле Сумма подсчитывалось автоматически. Этим вопросом сейчас и займемся.

Рассчитываем сумму в строке

И так открываем конфигуратор заходим в созданный ранее документ и переходим на вкладку Формы. В ней нужно открыть и отредактировать Форма Документа кликаем на ней два раза или выбираем Карандашик.

Как рассчитать сумму в строке табличной

Теперь необходимо перейти в Модуль.

сумма колонки табличной части 1с

В окне модуля пишем небольшой код

&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
Строка = Элементы.Материалы.ТекущиеДанные;
Строка.Сумма=Строка.Количество*Строка.Цена;
КонецПроцедуры

&НаКлиенте
Процедура МатериалыЦенаПриИзменении(Элемент)
Строка = Элементы.Материалы.ТекущиеДанные;
Строка.Сумма=Строка.Количество*Строка.Цена;
КонецПроцедуры

сумма в подвале табличной части 1с

Теперь немного поясню код который нужно написать.

&НаКлиенте – Это значить что вычисление будет происходить на компьютере пользователя, а не на сервере.

Процедура – Это собственно процедура)

МатериалыКоличествоПриИзменении – Это название нашей процедуры.

Строка – Это переменная

Элементы.Материалы.ТекущиеДанные – Этой строкой мы получаем данные строки.

Строка.Сумма=Строка.Количество*Строка.Цена – Это формула (Строка.Сумма, Строка.Количество, Строка.Цена этими строчками мы обращаемся к значениям которые находятся в таблице)

КонецПроцедуры – Это как вы уже догадались конец процедуры.

После чего запускаем отладку и проверяем. Для этого в документе вводим значения в поля Количество и Цена после чего сумма должна подставиться автоматически.

Вот вы и узнали, как рассчитать сумму в строке табличной части.

Скриншоты, опубликованные в данной статье, являются цитатами и иллюстрациями программного продукта “1C:Предприятие”, авторское право на который принадлежит ЗАО 1С.

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

2 комментария “Сумма в табличной части”